17. Mikrotik Give Priority to Speedtest.net



Here is a script:

/ip firewall filter
add action=add-dst-to-address-list address-list=Speedtest-List chain=forward \
    comment=Dst-Speedtest-List content=speedtest.net

/ip firewall mangle
add action=mark-connection chain=forward comment=Speedtest.Net \
    connection-state=new dst-address-list=Speedtest-List new-connection-mark=\
    Speedtest-conn
add action=mark-packet chain=forward connection-mark=Speedtest-conn \
    new-packet-mark=Speedtest-conn passthrough=no
add action=mark-connection chain=forward comment=Other connection-state=new \
    dst-address-list=!Speedtest-List new-connection-mark=Other-conn
add action=mark-packet chain=forward connection-mark=Other-conn \
    new-packet-mark=Other-conn passthrough=no

/queue simple
add max-limit=1M/1M name=LAN target=ether3
add max-limit=1M/1M name=SpeedTest.Net packet-marks=Speedtest-conn \
    parent=LAN priority=1/1 target=""
add max-limit=1M/1M name=Other packet-marks=Other-conn parent=LAN target=\
    "" 

From Now on, no need to test speed direct from router. You can test from any host on your LAN. You will see your real bandwidth.
Previous
Next Post »